Browse Source

provide compatibility with sqlalchemy 0.4

* fix sqlalchemy imports (fixes #6)
 * set runtime dependencies to sqlalchemy >= 0.4 and
   sqlalchemy-migrate >= 0.4


git-svn-id: file:///home/www/usr01/svn/gnuviechadmin/trunk@245 a67ec6bc-e5d5-0310-a910-815c51eb3124
master
Jan Dittberner 14 years ago
parent
commit
639b58df6e
  1. 2
      gnuviechadmin/backend/BackendTo.py
  2. 3
      gnuviechadmin/backend/tables.py
  3. 6
      setup.py

2
gnuviechadmin/backend/BackendTo.py

@ -19,7 +19,7 @@
#
# Version: $Id$
from sqlalchemy import object_mapper
from sqlalchemy.orm import object_mapper
from tables import *

3
gnuviechadmin/backend/tables.py

@ -20,6 +20,7 @@
# Version: $Id$
from sqlalchemy import *
from sqlalchemy.exceptions import NoSuchTableError
import sys
import migrate.versioning.api
from settings import *
@ -37,7 +38,7 @@ to fix this.""" %
(dbversion, required_version, config.get('database', 'uri'),
config.get('database', 'repository')))
sys.exit(1)
except exceptions.NoSuchTableError, nste:
except NoSuchTableError, nste:
print nste
sys.exit(1)

6
setup.py

@ -1,5 +1,5 @@
# -*- python -*-
# -*- coding: UTF-8 -*-
# -*- coding: utf-8 -*-
#
# Copyright (C) 2007 by Jan Dittberner.
#
@ -28,8 +28,8 @@ setup(
packages = find_packages(),
scripts = ['bin/gva'],
install_requires = ['sqlalchemy >= 0.3.10',
'migrate >= 0.3' ],
install_requires = ['sqlalchemy >= 0.4',
'sqlalchemy-migrate >= 0.4' ],
setup_requires = [],
include_package_data = True,

Loading…
Cancel
Save